GitHub header

Copilot Code Review is degraded, and not returning responses to users

Incident Report for GitHub

Resolved

On December 15, 2025, between 15:15 UTC and 18:22 UTC, Copilot Code Review experienced a service degradation that caused 46.97% of pull request review requests to fail, requiring users to re-request a review. Impacted users saw the error message: “Copilot encountered an error and was unable to review this pull request. You can try again by re-requesting a review.” The remaining requests completed successfully.

The degradation was caused by elevated response times in an internal, model-backed dependency, which led to request timeouts and backpressure in the review processing pipeline, resulting in sustained queue growth and failed review completion.

We mitigated the issue by temporarily bypassing fix suggestions to reduce latency, increasing worker capacity to drain the backlog, and rolling out a model configuration change that reduced end-to-end latency. Queue depth and request success rates returned to normal and remained stable through peak traffic.

Following the incident, we increased baseline worker capacity, added instrumentation for worker utilization and queue health, and are improving automatic load-shedding, fallback behavior, and alerting to reduce time to detection and mitigation for similar issues.
Posted Dec 15, 2025 - 18:22 UTC

Update

We have seen recovery for Copilot Code Review requests and are investigating long-term availability and scaling strategies
Posted Dec 15, 2025 - 18:21 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Dec 15, 2025 - 17:43 UTC