GitHub header

Intermittent networking failures across GitHub-hosted Actions runners

Incident Report for GitHub

Resolved

On December 18th, 2025, from 08:15 UTC to 17:11 UTC, some GitHub Actions runners experienced intermittent timeouts for Github API calls, which led to failures during runner setup and workflow execution. This was caused by network packet loss between runners in the West US region and one of GitHub’s edge sites. Approximately 1.5% of jobs on larger and standard hosted runners in the West US region were impacted, 0.28% of all Actions jobs during this period.

By 17:11 UTC, all traffic was routed away from the affected edge site, mitigating the timeouts. We are working to improve early detection of cross-cloud connectivity issues and faster mitigation paths to reduce the impact of similar issues in the future.
Posted Dec 18, 2025 - 17:41 UTC

Update

We are observing recovery with request from GitHub-hosted Actions runners and will continue to monitor.
Posted Dec 18, 2025 - 17:29 UTC

Update

Since approximately 8:00 UTC, we have observed intermittent failures on GitHub-hosted actions runners. The failures have been observed both during runner setup, and workflow execution. We are continuing to investigate.

Self-hosted runners are not impacted.
Posted Dec 18, 2025 - 16:35 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Dec 18, 2025 - 16:33 UTC
This incident affected: Actions.