GitHub header

Incident with Copilot

Incident Report for GitHub

Resolved

On February 10, 2026, between 10:28 and 11:54 UTC, Visual Studio Code users experienced a degraded experience on GitHub Copilot when using the Claude Opus 4.6 model. During this time, approximately 50% of users encountered agent turn failures due to the model being unable to serve the volume of incoming requests.

Rate limits set too low for actual demand caused the issue. While the initial deployment showed no concerns, a surge in traffic from Europe on the following day caused VSCode to begin hitting rate limit errors. Additionally, a degradation message intended to notify users of high usage failed to trigger due to a misconfiguration. We mitigated the incident by adjusting rate limits for the model.

We improved our rate limiting to prevent future models from experiencing similar issues. We are also improving our capacity planning processes to reduce the risk of similar incidents in the future, and enhancing our detection and mitigation capabilities to reduce impact to customers.
Posted Feb 06, 2026 - 11:58 UTC

Update

Copilot is operating normally.
Posted Feb 06, 2026 - 11:58 UTC

Update

We have increased capacity and are seeing recovery.
Posted Feb 06, 2026 - 11:57 UTC

Update

Opus 4.6 is currently experiencing high demand and we are working on adding capacity.
Posted Feb 06, 2026 - 11:21 UTC

Investigating

We are investigating reports of degraded performance for Copilot
Posted Feb 06, 2026 - 11:16 UTC
This incident affected: Copilot.